Тестовый курс
Ветер НаталияТатарникова Людмила Анатольевна

Тестовый курс

Демонстрационный курс создан для тестирования возможностей системы, проверки совместимости старых и возможностей новых модулей, управления пользователями, передачи данных и т.д.

Это описание (в тестовых целях) должно быть длинным, поэтому добавлю "просто текста":

Новые возможности Moodle 3.5 

Требования к серверу

Это только минимальные поддерживаемые версии. Мы рекомендуем регулярно обновлять все программное обеспечение и операционные системы.

  • Обновление Moodle: Moodle 3.1 или более поздняя версия
  • >Версия PHP: минимум PHP 7.0.0 Примечание: минимальная версия PHP увеличилась с Moodle 3.3 . PHP 7.1.x и 7.2.x также поддерживаются. PHP 7.x может иметь некоторые  ограничения движка .
  • Начиная с Moodle 3.4 требуется расширение PHP intl (оно было рекомендовано в версии 2.0 и далее)
  • (Только для рекомендаций) Если вы используете MySQL или MariaDB, убедитесь, что ваша база данных поддерживает полный UTF-8 (utf8mb4), если вы устанавливаете новый экземпляр Moodle. Сценарий CLI может использоваться для преобразования в utf8mb4 при обновлении. Вы можете продолжать использовать utf8_ *, но тогда предупреждение покажет, что база данных не использует полную поддержку UTF-8, и предложит перейти к utf8mb4_unicode_ci. Подробности смотрите в  полной поддержке юникода MySQL . Если вы включили utf8mb4, вы * должны * использовать формат файла Barracuda.